Project

General

Profile

Actions

Bug #5584

closed

several firmware files apparently do not get built

Added by osmith 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/20/2022
Due date:
% Done:

0%

Spec Reference:

Description

mschramm wrote:

looking at https://ftp.osmocom.org/binaries/simtrace2/firmware/latest/ , it shows that ngff_cardem-blupdate-dfu-latest.bin has a time/date from today, but its elf version ngff_cardem-blupdate-dfu-latest.elf is from December... ? In the /all/ subdir, no recent elf for 0.8.1.34-e450 seems to have been built .

when sorting by last modified, as of writing these are up-to-date:

simtrace-trace-dfu-latest.bin    2022-Jun-20 15:49:28    23.1K    application/octet-stream
simtrace-dfu-flash-latest.elf    2022-Jun-20 15:49:28    284.1K    application/octet-stream
simtrace-dfu-flash-latest.bin    2022-Jun-20 15:49:28    13.1K    application/octet-stream
simtrace-cardem-dfu-latest.bin    2022-Jun-20 15:49:28    27.2K    application/octet-stream
simtrace-blupdate-dfu-latest.bin    2022-Jun-20 15:49:28    26.0K    application/octet-stream
qmod-dfu-flash-latest.elf    2022-Jun-20 15:49:28    292.2K    application/octet-stream
qmod-dfu-flash-latest.bin    2022-Jun-20 15:49:28    13.5K    application/octet-stream
qmod-cardem-dfu-latest.bin    2022-Jun-20 15:49:28    32.9K    application/octet-stream
qmod-blupdate-dfu-latest.bin    2022-Jun-20 15:49:28    26.0K    application/octet-stream
owhw-dfu-flash-latest.elf    2022-Jun-20 15:49:28    284.6K    application/octet-stream
owhw-dfu-flash-latest.bin    2022-Jun-20 15:49:28    13.1K    application/octet-stream
owhw-cardem-dfu-latest.bin    2022-Jun-20 15:49:28    28.7K    application/octet-stream
owhw-blupdate-dfu-latest.bin    2022-Jun-20 15:49:28    26.0K    application/octet-stream
octsimtest-cardem-dfu-latest.bin    2022-Jun-20 15:49:28    29.0K    application/octet-stream
ngff_cardem-trace-dfu-latest.bin    2022-Jun-20 15:49:28    26.4K    application/octet-stream
ngff_cardem-dfu-flash-latest.elf    2022-Jun-20 15:49:28    308.0K    application/octet-stream
ngff_cardem-dfu-flash-latest.bin    2022-Jun-20 15:49:28    14.2K    application/octet-stream
ngff_cardem-cardem-dfu-latest.bin    2022-Jun-20 15:49:28    29.3K    application/octet-stream
ngff_cardem-blupdate-dfu-latest.bin    2022-Jun-20 15:49:28    26.0K    application/octet-stream

and these are outdated:

simtrace-trace-dfu-latest.elf    2021-Dec-15 07:52:19    291.3K    application/octet-stream
simtrace-cardem-dfu-latest.elf    2021-Dec-15 07:52:19    330.0K    application/octet-stream
simtrace-blupdate-dfu-latest.elf    2021-Dec-15 07:52:19    199.3K    application/octet-stream
qmod-cardem-dfu-latest.elf    2021-Dec-15 07:52:19    362.6K    application/octet-stream
qmod-blupdate-dfu-latest.elf    2021-Dec-15 07:52:19    199.2K    application/octet-stream
owhw-cardem-dfu-latest.elf    2021-Dec-15 07:52:19    333.4K    application/octet-stream
owhw-blupdate-dfu-latest.elf    2021-Dec-15 07:52:19    199.3K    application/octet-stream
octsimtest-cardem-dfu-latest.elf    2021-Dec-15 07:52:19    347.0K    application/octet-stream
ngff_cardem-trace-dfu-latest.elf    2021-Dec-15 07:52:19    334.9K    application/octet-stream
ngff_cardem-cardem-dfu-latest.elf    2021-Dec-15 07:52:19    351.5K    application/octet-stream
simtrace-dfu-flash-padded-latest.bin    2021-Dec-15 07:52:18    16.0K    application/octet-stream
qmod-dfu-flash-padded-latest.bin    2021-Dec-15 07:52:18    16.0K    application/octet-stream
owhw-dfu-flash-padded-latest.bin    2021-Dec-15 07:52:18    16.0K    application/octet-stream
ngff_cardem-dfu-flash-padded-latest.bin    2021-Dec-15 07:52:18    16.0K    application/octet-stream
ngff_cardem-blupdate-dfu-latest.elf    2021-Dec-15 07:52:18    199.3K    application/octet-stream
simtrace-dfu-dfu-latest.elf    2021-Nov-24 07:52:28    218.9K    application/octet-stream
simtrace-dfu-dfu-latest.bin    2021-Nov-24 07:52:28    12.8K    application/octet-stream
qmod-dfu-dfu-latest.elf    2021-Nov-24 07:52:28    227.1K    application/octet-stream
qmod-dfu-dfu-latest.bin    2021-Nov-24 07:52:28    13.2K    application/octet-stream
owhw-dfu-dfu-latest.elf    2021-Nov-24 07:52:28    219.4K    application/octet-stream
owhw-dfu-dfu-latest.bin    2021-Nov-24 07:52:28    12.8K    application/octet-stream
ngff_cardem-dfu-dfu-latest.elf    2021-Nov-24 07:52:28    242.8K    application/octet-stream
ngff_cardem-dfu-dfu-latest.bin    2021-Nov-24 07:52:28    13.8K    application/octet-stream

I thought this is caused by jenkins not wiping the workspace. but even after configuring jenkin to wipe the workspace, the result is the same. So it looks like these targets are not getting built in the Makefile?

According to git log, Eric worked a lot on the Makefiles, assigning to you.


Related issues

Related to SIMtrace 2 - Feature #5772: build of "combined" firmware image for initial flashing during productionResolvedlaforge11/15/2022

Actions
Actions #1

Updated by laforge 6 months ago

Hoernchen ping? This has been pending for one month

Actions #2

Updated by laforge 3 months ago

Hoernchen, any update? It has been 5 months sicne the issue was created, and 4 months since my last reminder?

Actions #3

Updated by Hoernchen 3 months ago

The reminder happened while I was involuntarily "absent" for a long amount of time and I was busy with other completely unrelated work...

Actions #4

Updated by Hoernchen 3 months ago

  • Status changed from New to Rejected

The reason why the dfu-dfu files do not exist is because that target does not exist, it was replaced by the blupdater. The reason why the other elf binaries do not exist is because there is no working elf file, there is only the intermediate elf file without the crc stub and deliberately broken stack init values that is unusable by itself which then gets transformed into the bin file by adding the crcstub. There is nothing to fix here.

Actions #5

Updated by mschramm 3 months ago

Hoernchen wrote in #note-4:

There is nothing to fix here.

Hmm.. but then at least purging all !*-dfu-dfu-* files in that dir?!

regarding the elf files: I usually don't need them for gdb; likely everybody in need of such use can produce them themselves.

But the "padded" files remain outdated; they are an intermediate for the "combined" files, - which are not built at all. And those "combined" files are what I use for flashing the QMOD in the test rig (in 1st stage), so, as they are absent here, this requires me to always build the combined versions locally, with the help of also locally-build "padded" intermediates... So I end up with building it all locally, because I can't use our ftp dl repo because of the mentioned issue.

Actions #6

Updated by Hoernchen 3 months ago

The padded files are completely useless and should never have been published at all anyway, since they only serve as intermediate step when building the combined images, which also were never published. The lack of published combined firmware files for (production) jtag flashing of bl+app at the same time is a different issue not related to this ticket.

Actions #7

Updated by laforge 3 months ago

  • Status changed from Rejected to New
Actions #8

Updated by laforge 3 months ago

On Mon, Nov 14, 2022 at 09:10:47PM +0000, mschramm wrote:

Hmm.. but then at least purging all !*-dfu-dfu-* files in that dir?!

Indeed, For latest we should probably remove them (just did that)

For the old builds in the 'all' they should remain as history.

regarding the elf files: I usually don't need them for gdb; likely everybody in need of such use can produce them themselves.

Publishing the elf files on ftp.osmocom.org is required if you want to debug a problem that you can observe with a production firmware build. This is why they've always been there.

If you build the same version locally the symbols will not match to the
official bin file builds. So you can only use locally generated elf
files for gdb if you also installed the locally-built .bin file along
with it. That is unlikely the case for any random problem you
encountered while using the production firmware bin files from ftp.

So I don't really see why we'd stop publishing the elf files suddenly?

But the "padded" files remain outdated; they are an intermediate for the "combined" files, -

done, I've removed them.

And those "combined" files are what I use for flashing the QMOD in the test rig (in 1st stage), so, as they are absent here, this requires me to always build the combined versions locally,

If you would something like a combined file to be auto-built/published,
just ask for it. Preferably in a feature ticket, as right here it is
about something that is missing from before (at least in the case of the
elf files it appears indeed a bug)

Actions #9

Updated by Hoernchen 3 months ago

  • Status changed from New to Resolved
Actions #10

Updated by mschramm 2 months ago

  • Related to Feature #5772: build of "combined" firmware image for initial flashing during production added
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)