Project

General

Profile

Actions

Bug #5794

closed

ansible: install-poky-sdk fails on new debian11 lxc

Added by laforge 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/27/2022
Due date:
% Done:

100%

Spec Reference:

Description

TASK [install-poky-sdk : execute poky installer] ********************************************************
fatal: [host2-deb11build-ansible]: FAILED! => {
    "changed": true,
    "cmd": [
        "/tmp/poky-glibc-x86_64-meta-toolchain-osmo-cortexa15hf-neon-toolchain-osmo-2.3.4.sh",
        "-y",
        "-d",
        "/opt/poky-oc2g/2.3.4/" 
    ],
    "delta": "0:00:10.410595",
    "end": "2022-11-27 12:43:31.401707",
    "rc": 1,
    "start": "2022-11-27 12:43:20.991112" 
}

STDOUT:

Poky (Yocto Project Reference Distro) SDK installer version 2.3.4
=================================================================
You are about to install the SDK to "/opt/poky-oc2g/2.3.4". Proceed[Y/n]? Y
Extracting SDK....................................done
Setting it up...Failed to replace perl. Relocate script failed. Abort!

STDERR:

/tmp/poky-glibc-x86_64-meta-toolchain-osmo-cortexa15hf-neon-toolchain-osmo-2.3.4.sh: 28: gcc: not found
xargs: file: No such file or directory
sed: no input files

MSG:

non-zero return code
Actions #1

Updated by laforge 2 months ago

  • Assignee set to osmith

this prevents me from creating new deb11build containers on host2 + build3.

Actions #3

Updated by laforge 2 months ago

you can reproduce the problem trying to deploy against the new executors in https://gerrit.osmocom.org/c/osmo-ci/+/30342

Actions #4

Updated by osmith 2 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

I didn't have the sdk binaries installed, and so the task got skipped and ansible finished successfully. Afterwards I downloaded the binaries and ran the script again, and this succeeded as well. From the output above it looks like "file" and "gcc" were not installed at the time this ran initially, created a patch to install it:
https://gerrit.osmocom.org/c/osmo-ci/+/30343

I've added the new nodes to jenkins.

Actions #5

Updated by laforge 2 months ago

thanks. At least 'gcc' was definitely present at the time I ran into the problems stated above, I tried that. As for 'file', I doubt a basic debian lxc comes without it.

Actions #6

Updated by osmith 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)