Project

General

Profile

Actions

Bug #5888

closed

add a second wildcard APN in S6a

Added by lynxis about 1 year ago. Updated 12 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/01/2023
Due date:
% Done:

100%


Description

Currently the osmo_dia2gsup is responding to a UpdateLocationRequest" on the diameter side with a
UpdateLocationAnswer with the subscriber data containing a single static entry for the APN containing internet .

UpdateLocationAnswer {
 [..],
 Subscription-Data {
   APN Configuration Profile {
     APN Configuration {
      [ Service Selection = "internet" ]
     }
   }
 }
}

Since our HLR/GSUP isn't sending a correct APN list (currently only a wildcard, instead of a correct default apn and (depending on the subscriber data) also a wildcard.
An intermediate solution to be implemented by this ticket should be:

- sending 2 profiles
- one for apn "internet"
- one for wildcard

Actions #1

Updated by daniel about 1 year ago

See https://github.com/open5gs/open5gs/pull/652 for an (unfortunately closed) PR to support wildcard APN in open5gs

Actions #2

Updated by daniel about 1 year ago

fixeria would this be something you could implement since you know more erlang than I do?

Actions #3

Updated by fixeria about 1 year ago

Hi Daniel,

sorry for late feedback.

daniel wrote in #note-2:

fixeria would this be something you could implement since you know more erlang than I do?

I can work on that, but I am currently a bit busy with some other tasks. How urgent is this?

Actions #4

Updated by daniel about 1 year ago

fixeria wrote in #note-3:

Hi Daniel,

sorry for late feedback.

daniel wrote in #note-2:

fixeria would this be something you could implement since you know more erlang than I do?

I can work on that, but I am currently a bit busy with some other tasks. How urgent is this?

Well, we have a hack/workaround in place that works right now so it's not super urgent. Would be nice to clean this up eventually.

Actions #5

Updated by lynxis 12 months ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100

I've implemented this but Open5gs doesn't implement the wildcard APN.
I've fixed the root cause of this feature (having a configurable subscription data/APN list in osmo-hlr).
https://gerrit.osmocom.org/q/topic:multiple-apns

I'll push this commit to gerrit and mark it abandoned afterwards to have this commit laying around.

Actions #6

Updated by lynxis 12 months ago

  • Assignee set to lynxis
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)