Project

General

Profile

Actions

Bug #5999

closed

m3ua.c logs "LEN=268435456"

Added by neels 11 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/11/2023
Due date:
% Done:

0%

Spec Reference:

Description

with attached configs, i start osmo-stp and osmo-msc, and see this error:

2023-04-11,22:58:47.282 DLM3UA ERROR 0: asp-asp-clnt-msc-0: Received MGMT_ERR 'Invalid Routing Context': HDR=(MGMT:ERROR,V=1,LEN=268435456), PART (m3ua.c:586)

LEN=268435456 cannot be right. figure out how this random / corrupted value appears.

The cfg files are not correct, i am just busy figuring something out.
I just know that no weird config file should be able to provoke memory corruption.


Files

osmo-stp.cfg osmo-stp.cfg 889 Bytes neels, 04/11/2023 09:02 PM
osmo-msc.cfg osmo-msc.cfg 838 Bytes neels, 04/11/2023 09:02 PM
Actions #1

Updated by laforge 4 months ago

  • Status changed from New to Feedback
  • Assignee set to neels

it would be very useful to have a pcap file containign the MGMT/ERROR message that generates this log line so one can analyze it.

Actions #2

Updated by neels 3 months ago

  • Status changed from Feedback to Rejected

Hmm, I cannot reproduce the problem anymore. Maybe it was a clumsy build incompat on my system.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)