Project

General

Profile

Actions

Bug #6001

closed

osmo-gsm-tester_virtual: netreg_mass fails: Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle

Added by osmith 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/12/2023
Due date:
% Done:

100%

Resolution:
Spec Reference:

Description

Since March 21 the netreg_mass test in osmo-gsm-tester_virtual has been failing. No MS is performing LU anymore.

22:51:01.677449 run                osmo-ms-mob/00098: Starting mobile
22:51:01.704068 run       osmo-ms-mob/00098(pid=234): Launched
22:51:01.723323 run                             mass: MS start registered  {at=8155812.010846457, delay=0.008084695786237717, ms=00098}
22:51:03.474475 run                osmo-ms-mob/00099: Starting mobile
22:51:03.500497 run       osmo-ms-mob/00099(pid=235): Launched
22:51:03.511270 run                             mass: All started... {duration=55.749718241393566, too_slow=0}
22:51:03.521608 run                             mass: MS start registered  {at=8155813.809176664, delay=0.010319825261831284, ms=00099}
22:52:07.825656 run                             mass: Tests done {all_completed=False, max=None, min=None}
22:52:07.840405 tst      register_default_mass.py:52: ERR: Exception: No run completed.  [trial-7152↪netreg_mass↪register_default_mass.py:52]
22:52:07.840904 tst      register_default_mass.py:52: Test FAILED (140.7 sec)

Looking at e.g. run.2023-04-11_22-49-48/netreg_mass/osmo-ms-mob/00000/stderr, it seems to be an error in the state machine:

(launched: 2023-04-11_22:50:09.822249)
<0013> script_lua.c:118 No handler for Shutdown
<0013> script_lua.c:118 No handler for Started
<0011> app_mobile.c:254 ***
Warning: Mobile '00000' has default IMEI: 000000000000000
<0011> app_mobile.c:256 This could relate your identitiy to other users with default IMEI.
***
<0011> app_mobile.c:278 Mobile '00000' initialized, please start phone now!
<001b> telnet_interface.c:88 Available via telnet 127.0.0.1 0
<0013> script_lua.c:118 No handler for Started
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.
<0005> gsm48_mm.c:4323 Message MM_EVENT_NO_CELL_FOUND unhandled in state MM idle.

Pau recently worked on related code, assigning to you.


Related issues

Blocks OsmoBTS - Feature #1572: Circuit Switched Data (CSD) Support in osmo-btsResolvedfixeria02/23/2016

Actions
Actions #1

Updated by fixeria 11 months ago

I guess this might be caused by one of my patches:

commit 4949ab7471370bf2d3b63e74c6846340dc638d06
Author: Vadim Yanitskiy <vyanitskiy@sysmocom.de>
Date:   Thu Mar 16 20:43:18 2023 +0700

    layer23/{mobile,modem}: prefix VTY prompt with project's name

    Change-Id: If7ce89362c75e2c15995dfb08cfcfdcad24e2529

Back in March I had to fix osmo-python-tests.git:

https://gerrit.osmocom.org/c/python/osmo-python-tests/+/32063 InteractVty: re.escape() the VTY prompt in connect()

but osmo-gsm-tester.git has its own implementation of the VTY interface, so I submitted another fix:

https://gerrit.osmocom.org/c/osmo-gsm-tester/+/32281 osmo_vty: re.escape() the VTY prompt in connect()

UPDATE: pespin reports that this does not solve the problem :/
https://jenkins.osmocom.org/jenkins/job/osmo-gsm-tester_virtual-pespin/6/console

Actions #2

Updated by pespin 11 months ago

  • Assignee changed from pespin to fixeria

Regression introduced by osmo-bts.git 8e04613e4f0bf5093e15a6027ac53e3934555708 "osmo-bts-trx: properly activate [CBCH/]BCCH/CCCH". I confirmed it by building a new osmo-bts trial with that patch reverted on top of current master: test then passes.

Actions #3

Updated by pespin 11 months ago

  • Blocks Feature #1572: Circuit Switched Data (CSD) Support in osmo-bts added
Actions #4

Updated by fixeria 11 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 80

pespin wrote in #note-2:

Regression introduced by osmo-bts.git 8e04613e4f0bf5093e15a6027ac53e3934555708 "osmo-bts-trx: properly activate [CBCH/]BCCH/CCCH". I confirmed it by building a new osmo-bts trial with that patch reverted on top of current master: test then passes.

I reproduced the problem running osmo-bts-virtual locally and submitted a fix:

https://gerrit.osmocom.org/c/osmo-bts/+/32285 osmo-bts-virtual: properly activate [CBCH/]BCCH/CCCH [NEW]

I makes virtphy on my machine "see" broadcast DL traffic again, so I believe it should fix the problem.

Actions #5

Updated by fixeria 11 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 80 to 100

Yup, this patch did the trick. Merged, the job is green again.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)