Project

General

Profile

Actions

Bug #6271

closed

do not execute a startup script on initialization errors

Added by dexter 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/23/2023
Due date:
% Done:

100%

Spec Reference:

Description

When there is an error at initialization (e.g. card is not present) and a startup script is passed with the command line option, then the script will execute anyway. This cause a lot of unnecessary error messages and confusion. pySim-shell should not continue executing a starup script when there were initialization errors!

Actions #1

Updated by dexter 3 months ago

  • Status changed from New to In Progress
Actions #2

Updated by dexter 3 months ago

  • % Done changed from 0 to 90

Here are two patches that should fix the problem:

https://gerrit.osmocom.org/c/pysim/+/35101 app: do not catch exceptions in init_card
https://gerrit.osmocom.org/c/pysim/+/35102 pySim-shell: refuse to execute a startup script on initialization errors

Actions #3

Updated by dexter 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

The problem is now fixed. We can close this ticket now.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)