Project

General

Profile

Actions

Bug #6278

closed

fix sending of raw APDUs

Added by dexter 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/29/2023
Due date:
% Done:

100%

Spec Reference:

Description

There is a problem when sending raw APDUs to cards that are not provisioned yet. The scc (SimCardCommands) object seems to be missing for some reason.

$ ./pySim-shell.py -p 0 
Using PC/SC reader number 0
Waiting for card...
Warning: Could not detect card type - assuming a generic card type...
Unsupported card type!
pySim-shell not equipped!
Welcome to pySim-shell!
(C) 2021-2023 by Harald Welte, sysmocom - s.f.m.c. GmbH and contributors
Online manual available at https://downloads.osmocom.org/docs/pysim/master/html/shell.html 
pySIM-shell (no card profile)> apdu 0000000000
EXCEPTION of type 'AttributeError' occurred with message: ''SimCardBase' object has no attribute 'scc''
To enable full traceback, run the following command: 'set debug true'
pySIM-shell (no card profile)> 
Actions #1

Updated by dexter 3 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90
Actions #2

Updated by dexter 3 months ago

There is now a patch in review that should fix the problem: https://gerrit.osmocom.org/c/pysim/+/35161 pySim-shell: Do not use self.lchan.scc when sending raw APDUs.

Actions #3

Updated by dexter 3 months ago

  • % Done changed from 90 to 100

The problem is now fixed. We can close this ticket now.

Actions #4

Updated by dexter 3 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)