Project

General

Profile

Actions

Bug #6430

closed

"distcheck" suddenly fails for gerrit-pysim on jenkins slaves

Added by laforge 10 days ago. Updated 10 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/03/2024
Due date:
% Done:

100%

Spec Reference:

Description

https://jenkins.osmocom.org/jenkins/job/gerrit-pysim-build/JOB_TYPE=distcheck,a1=default,a3=default,a4=default,label=osmocom-gerrit/1102/consoleFull

...
+ virtualenv -p python3 venv --system-site-packages
/build/contrib/jenkins.sh: 36: virtualenv: not found
Build step 'Execute shell' marked build as failure
Finished: FAILURE

I'm not aware that the pysim project introduced any recent changes which would suddenly require virtualenv where it was not required before. I would assume we always needed it?

Actions #1

Updated by osmith 10 days ago

  • Status changed from New to In Progress

regression from https://gerrit.osmocom.org/c/pysim/+/36383 apparently, looking into it

Actions #2

Updated by fixeria 10 days ago

osmith wrote in #note-1:

regression from https://gerrit.osmocom.org/c/pysim/+/36383 apparently, looking into it

Looks like my patch is the culprit here, sorry.
This is probably because initially the plan was to execute this job on the simtester machine, which has the necessary packages:

https://cgit.osmocom.org/osmo-ci/commit/?id=31fd5cf020baae3c33adb3cc23632ccd59c4456e

So the problem is that the osmocom-gerrit machine does not have the virtualenv package.

BTW, do we really want to execute this job for every patch being submitted?
It's not like we add new packages too often, so executing once a day (pysim-master job) would probably be enough?

Actions #3

Updated by osmith 10 days ago

  • % Done changed from 0 to 90

So the problem is that the osmocom-gerrit machine does not have the virtualenv package.

https://gerrit.osmocom.org/c/docker-playground/+/36516

BTW, do we really want to execute this job for every patch being submitted?
It's not like we add new packages too often, so executing once a day (pysim-master job) would probably be enough?

The job only takes 10 seconds (see https://jenkins.osmocom.org/jenkins/job/gerrit-pysim-build/JOB_TYPE=distcheck,a1=default,a3=default,a4=default,label=osmocom-gerrit/).

I think it is fine to run it on every patch submitted, and it saves us from making mistakes there before patches get merged which is very useful. Similar to the debian package build tests.

Actions #4

Updated by osmith 10 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)