Project

General

Profile

Actions

SoftwareLicensing » History » Revision 3

« Previous | Revision 3/7 (diff) | Next »
laforge, 02/19/2016 10:47 PM


= Software Licensing =

OpenBSC executable programs
The following notes apply to software described on this wiki, developed as part of the Osmocom project.
Specifically, it applies to OpenBSC, osmo-bsc, osmo-sgsn, gb_proxy, ipaccess-config, bsc_nat, bsc_mgcp, ...

For reasons of simplicity, we always call it ''OpenBSC'' here.

'''OpenBSC is copyrighted software like any other computer program. In order to use OpenBSC, you need
a license from the copyright holders.'''

If you do not arrange for a different license with the copyright holders, the software ships with a
default license: The [http://fsf.org/licenses/agpl-3.0.html AGPLv3] (GNU Affero General Public License, Version 3).

==== General idea behind the License ====

The general idea behind our licensing model is as follows: You receive the full source code of
the OpenBSC software and can use it like you see fit, '''but''' we require you to release the
source code of any modifications or derivative work you create.

With AGPL, it does not matter whether you ever distribute the OpenBSC software. As soon as you
provide a GSM network using OpenBSC, all users are entitled to receive a copy of the license text
and the ''complete corresponding source code'' of the very version you are using to run the GSM network with.

=== Alternative Licenses / Dual Licensing ===

If you do not agree to the abovementioned conditions, you may contact the copyright holders and apply for
an alternative license. Business details will depend on your intended use case, size of the installation, ...

libosmocore

The {{{libosmocore}}}. {{{libosmovty}}} and {{{libosmogsm}}} libraries are licensed under GPLv2+, i.e.
"GNU GPL Version 2, or any later version". This means at the time of this writing, you can license them
under either [http://www.gnu.org/licenses/gpl-2.0.html GPLv2] or [http://www.gnu.org/licenses/gpl-3.0.html GPLv3].

As both GPLv2 and GPLv3 are ''strong copyleft'' licenses, it means that creating a derivative work of
the library and an executable program will require that executable program to be under the same GPL version.

If you use the libraries together with the Osmocom executable programs (see above), then libosmocore
will be licensed under GPLv3, which is compatible with the AGPLv3 of the executable programs.

Questions

If you have any questions regarding the licenses used in the Osmocom project, please contact the project
authors '''before''' you create any kind of product or a derivative work.

Updated by laforge almost 6 years ago · 3 revisions

Add picture from clipboard (Maximum size: 48.8 MB)