Project

General

Profile

Bug #1707

leaks test sessions

Added by lazlo over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/12/2016
Due date:
% Done:

0%

Spec Reference:

Description

When the osmo-gsm-tester has run more than one session, "events" like received SMS will be dispatched to test cases of previous test sessions.

This does not lead to the failure of the current session but is irritating and simply a bug.

An example for this situation can be seen in the log output of the tester

20160427185631   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" on_tick called (ttl 145 seconds)
20160427185631   DEBUG: IN tick_scenario(): tests total 1 tests complete 0 test failed 0
20160427185633   DEBUG: IN tick_scenario(): steps total 1 steps complete 0
20160427185633   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" on_tick called (ttl 143 seconds)
20160427185633   DEBUG: IN tick_scenario(): tests total 1 tests complete 0 test failed 0
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.xHnW1CNJVu-build-302>:StandardTestScenario<0xe02910>:SendMOSmsTestCase<0xe02b90>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.xHnW1CNJVu-build-302>:StandardTestScenario<0xe02910>:SendMOSmsTestCase<0xe02bd0>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: "TestSession<tmp.xHnW1CNJVu-build-302>:StandardTestScenario<0xe02910>:SendMOSmsTestCase<0xe02bd0>" message was directed at 'to_modem' (/wavecom_3)
20160427185634   DEBUG: "TestSession<tmp.xHnW1CNJVu-build-302>:StandardTestScenario<0xe02910>:SendMOSmsTestCase<0xe02bd0>" state = failure
20160427185634    INFO: "TestSession<tmp.xHnW1CNJVu-build-302>:StandardTestScenario<0xe02910>:SendMOSmsTestCase<0xe02bd0>" failure! random token mismatch (expected 0.460211981162)
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.32HecBvzWT-build-303>:StandardTestScenario<0xe0c890>:SendMOSmsTestCase<0xe0c950>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.32HecBvzWT-build-303>:StandardTestScenario<0xe0c890>:SendMOSmsTestCase<0xe0c990>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: "TestSession<tmp.32HecBvzWT-build-303>:StandardTestScenario<0xe0c890>:SendMOSmsTestCase<0xe0c990>" message was directed at 'to_modem' (/wavecom_3)
20160427185634   DEBUG: "TestSession<tmp.32HecBvzWT-build-303>:StandardTestScenario<0xe0c890>:SendMOSmsTestCase<0xe0c990>" state = failure
20160427185634    INFO: "TestSession<tmp.32HecBvzWT-build-303>:StandardTestScenario<0xe0c890>:SendMOSmsTestCase<0xe0c990>" failure! random token mismatch (expected 0.184061419514)
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09750>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: Message: test message from TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790> (rand_token=0.744257599003)
20160427185634   DEBUG: Path: /wavecom_3
20160427185634   DEBUG: Interface: org.ofono.MessageManager
20160427185634   DEBUG:     LocalSentTime = 2016-04-27T18:56:30+0200
20160427185634   DEBUG:     SentTime = 2016-04-27T16:56:30+0000
20160427185634   DEBUG:     Sender = 7803
20160427185634   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" received message (not sure yet if it is for this test case)
20160427185634   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" message was directed at 'to_modem' (/wavecom_3)
20160427185634   DEBUG: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" state = success
20160427185634    INFO: "TestSession<tmp.BRUwIH6e9z-build-304>:StandardTestScenario<0xf09690>:SendMOSmsTestCase<0xf09790>" success! took 37 seconds to deliver SMS to 7804
20160427185635   DEBUG: IN tick_scenario(): steps total 1 steps complete 0

Note that this jenkins build job failed not because of the tester but because the final "ssh rm -rf" failed.

+ ssh root@10.9.1.190 rm -rf /var/tmp/osmo-gsm-tester/tmp.BRUwIH6e9z-build-304
rm: cannot remove `/var/tmp/osmo-gsm-tester/tmp.BRUwIH6e9z-build-304': Directory not empty
Build step 'Execute shell' marked build as failure
[WARNINGS] Skipping publisher since build result is FAILURE
Recording test results
Archiving artifacts
Finished: FAILURE

Reproduce the bug run at least two test sessions and you will notice that an SMS that originates from a test case of the current test session will be dispatched to test cases of the previous test sessions (see TestSession<some-unique-value> in the log output) and these test cases will be marked as "failure" (which does not change the outcome of the current test session).

History

#1 Updated by lazlo over 4 years ago

  • Description updated (diff)

#2 Updated by lazlo over 4 years ago

  • Status changed from New to In Progress

In commit 6f2b87d I added a "if" inside on_receive() method in the tc_sendmosms.py test case that will make sure, events/messages are only accepted if the test is in TEST_RUNNING state.

That should fix the issue of an event being dispatched to all existing/previous test sessions and their test cases.

#3 Updated by lazlo over 4 years ago

  • Status changed from In Progress to Resolved

Haven't had any issues with leaking sessions after commit 6f2b87d.

#4 Updated by laforge over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)