Project

General

Profile

Bug #1744

1-way voice between sysmobts and nanobts if DTX is enabled

Added by msuraev about 2 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/03/2016
Due date:
% Done:

0%

Estimated time:
Spec Reference:

Description

Not sure if it's osmobts or openbsc to blame but in following setup there's 1-way audio:

ms1 <-> sysmobts <-> openbsc <-> nanobts <-> ms2

The audio ms2 -> ms1 can be heard (if -P option is used for openbsc than some stattering in voice is audible, not sure if it's a separate issue) but the audio ms1 -> ms2 is nonexistent. In some test 1-2 words could be heard before audio is gone. Switching phones change nothing.

OpenBSC is configured for full-rate channels with AMR codec in the attached .pcap although the same effect could be observed with other codecs too.


Related issues

Related to OsmoBTS - Feature #1562: Uplink DTX supportClosed2016-02-232016-06-10

History

#1 Updated by msuraev about 2 years ago

In the attached .pcap 10.9.23.140 is nanobts, 10.9.1.191 is sysmobts and 10.9.1.105 is openbsc.

#2 Updated by msuraev about 2 years ago

By mistake I've tested with dtx enabled. Attached file is test with disabled DTX and voice works fine in this case.

#4 Updated by msuraev about 2 years ago

  • Assignee set to msuraev

#5 Updated by msuraev about 2 years ago

#6 Updated by laforge about 2 years ago

  • Assignee deleted (msuraev)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)