Project

General

Profile

Bug #1779

Problems with automatic subscriber creation.

Added by dexter over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OpenBSC
Target version:
-
Start date:
07/21/2016
Due date:
% Done:

0%

Resolution:
worksforme
Spec Reference:

Description

Maybe this is a problem with my configuration, but after long time I tried the automatic subscriber creation mode again. It constantly rejects the location update with the cause that no subscriber could be found. I traced the problem down to gsm_04_08.c:static bool subscr_regexp_check(). There the regexec() seems to fail.

The VTY show s the following:

OpenBSC> show network
BSC is on Country Code 1, Network Code 1 and has 1 BTS
Long network name: 'Vaderfone'
Short network name: 'Vaderfone'
Authentication policy: accept-all, authorized regexp: *
Auto create subscriber: yes
Auto assign extension: yes
Location updating reject cause: 13
Encryption: A5/0
NECI (TCH/H): 1
Use TCH for Paging any: 0
RRLP Mode: none
MM Info: On
Handover: Off
Current Channel Load:
Last RF Command:
Last RF Lock Command:

If i get things right, "authorized regexp: *" should be ok with any IMSI. When I hardcode the returnvalue of subscr_regexp_check() to true it accepts any IMSI again and happyly creates the subscriber.

History

#1 Updated by dexter over 3 years ago

  • Status changed from New to Closed

Max found the problem with the regex. (* => .*)

#2 Updated by dexter about 3 years ago

  • Status changed from Closed to Resolved

#3 Updated by laforge about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)