Project

General

Profile

Feature #1860

Include Ubuntu 16.04 LTS in nightly builds

Added by laforge over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/28/2016
Due date:
% Done:

100%

Estimated time:
Spec Reference:

Description

The osmocom nightly builds (https://build.opensuse.org/project/show/network:osmocom:nightly) should build packages also for Ubuntu 16.04, as it is the latest stable / long term support release.


Related issues

Related to Cellular Network Infrastructure - Bug #1920: some nightly packages from build.opensuse.org missingClosed2017-01-17

Related to OsmoNITB - Bug #1591: libdbi is buggy and slow, get rid of itClosed2016-02-23

Related to Cellular Network Infrastructure - Support #1923: re-enable all nightly package buildsRejected2017-01-19

History

#1 Updated by msuraev over 1 year ago

  • Status changed from New to Stalled
  • % Done changed from 0 to 10

There are currently build errors for osmo-trx and osmo-stp packages and 3 dependency problems due to libosmonetif library. However that's still result in twice the number of successfully built packages compared to 14.04

#2 Updated by msuraev over 1 year ago

  • Status changed from Stalled to In Progress

Gerrit # 1612 should fix the dependency issue.

#3 Updated by msuraev over 1 year ago

Merging gerrit # 1485 and its dependencies should help with fixing osmo-trx build.

#4 Updated by msuraev over 1 year ago

Correction: osmo-trx is failing due to uhd version requirements. There seems to be no way to point obs to external repo to look for dependencies so the only way to fix this is to add uhd packages to obs and to link to them. Not sure if it's worth the efforts.

#5 Updated by msuraev over 1 year ago

Note: added ppc64 to the build matrix as we've had problem with BE previously so it's good to have it as a test target.

#6 Updated by laforge over 1 year ago

On Mon, Jan 16, 2017 at 11:41:22AM +0000, msuraev [REDMINE] wrote:

Correction: osmo-trx is failing due to uhd version requirements. There
seems to be no way to point obs to external repo to look for
dependencies so the only way to fix this is to add uhd packages to obs
and to link to them. Not sure if it's worth the efforts.

I really don't think it is us who should pick up the pieces after Ettus'
(sorry) stupid decision to deprecate anyone with a current/stable Linux
distribution.

In fact, I think the proper solution is to re-introduce support for
older UHD versions in osmo-trx. How hard can it be?

Regards,
Harald

#7 Updated by laforge over 1 year ago

On Mon, Jan 16, 2017 at 11:42:45AM +0000, msuraev [REDMINE] wrote:

Note: added ppc64 to the build matrix as we've had problem with BE previously so it's good to have it as a test target.

The question is: Do we bother to support big-endian in general? Are
there any users to start worrying about this? Today, wtih ARM and x86
being by far the dominant architectures, why invest time if there's
nobody asking? The world was different some 10-15 years ago, when there
was a significant quantity of powerpc, (ultra)sparc and other big endian
systems out there, also among the users of OpenBSC.

#8 Updated by msuraev over 1 year ago

Removed ppc64 to avoid ML spam. Shall I disable/remove osmo-trx packages? Note, in approx 4 months problem with osmo-trx will be resolved automatically with the appearance of new ubuntu version - until when we can recommend building it locally using uhd packages from Ettus.

Also, what about Debian_Next repo - it's unused due to missing path. Seems like leftover as it's unsupport by OBS ATM. Shall I remove it?

#9 Updated by msuraev over 1 year ago

Which ubuntu versions shall we support? Latest LTS and latest non-LTS or some more?

#10 Updated by msuraev over 1 year ago

  • Related to Bug #1920: some nightly packages from build.opensuse.org missing added

#11 Updated by msuraev over 1 year ago

  • Status changed from In Progress to Stalled

#12 Updated by msuraev over 1 year ago

  • % Done changed from 10 to 40

After gerrit # 1612 has been merged (gerrit # 1616 is still under review) there are following errors:

16.04:
- openbsc fails due to db tests: it's a known bug in libdbi (will be fixed automatically once vlr work is merged)
- osmo-bts fails due to missing openbsc-dev (same happens on all repos, will check why)

Another notable failure is libosmo-netif fails on 16.10 x64 due to "make check" test failure which I'm unable to reproduce locally and there seems to be no way to download build artifacts from OBS to see why this happens.

#13 Updated by msuraev over 1 year ago

  • % Done changed from 40 to 80

Osmo-bts build failure should be fixed by gerrit # 1621 (currently under review).

#14 Updated by msuraev over 1 year ago

  • Related to Feature #1592: VLR in libmsc, to connect to HLR asynchronously added

#15 Updated by neels over 1 year ago

  • Related to deleted (Feature #1592: VLR in libmsc, to connect to HLR asynchronously)

#16 Updated by msuraev over 1 year ago

Gerrit 1636 is necessary to fix build of osmo-bts.

#17 Updated by msuraev over 1 year ago

osmo-trx can be re-enabled once gerrit 1635 is merged.

#18 Updated by msuraev over 1 year ago

  • Related to Bug #1591: libdbi is buggy and slow, get rid of it added

#19 Updated by msuraev over 1 year ago

  • Related to Support #1923: re-enable all nightly package builds added

#20 Updated by msuraev over 1 year ago

The packages have not been rebuild after 1636 merge yet.

#21 Updated by laforge over 1 year ago

On Mon, Jan 23, 2017 at 10:22:13AM +0000, msuraev [REDMINE] wrote:

Even after 1636 is merged, the build still fails - I'm unable to reproduce this error locally so far.

Just to make sure I understand you correctly: You are building the dpkg
packages on a local 16.04 LTS by hand and it works?

#22 Updated by msuraev over 1 year ago

laforge wrote:

On Mon, Jan 23, 2017 at 10:22:13AM +0000, msuraev [REDMINE] wrote:

Even after 1636 is merged, the build still fails - I'm unable to reproduce this error locally so far.

Just to make sure I understand you correctly: You are building the dpkg
packages on a local 16.04 LTS by hand and it works?

Yes: after building and installing openbsc-dev I can build osmo-bts locally. It seems like the OBS builds just have not been updated by jenkins yet - see corresponding question in ML.

#23 Updated by msuraev over 1 year ago

  • Status changed from Stalled to Resolved
  • Assignee changed from msuraev to laforge
  • % Done changed from 80 to 100

After merge of gerrit 1650-1654 all the packages are built for 16.04 on par with Debian. The remaining issue is related to #1591 and tracked via separate ticket #1923.

#24 Updated by laforge over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)