Project

General

Profile

Feature #2447

simple way to add subscribers to HLR

Added by laforge 11 months ago. Updated 5 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
-
Start date:
08/15/2017
Due date:
% Done:

100%

Estimated time:

Description

This could be via the VTY (similar to how it was done before) or by another means, but we should have a documented and straight-forward way to enter new subscribers into the database.


Related issues

Related to OsmoHLR - Feature #2359: Write OsmoHLR manualClosed2017-07-11

History

#1 Updated by laforge 10 months ago

#2 Updated by neels 10 months ago

  • Assignee changed from sysmocom to neels

My plan is to primarily add VTY commands more or less similar to OsmoNITB's subscriber commands.

Other nice-to-haves, possibly separate issues:
- add subscriber CTRL commands ( https://lists.osmocom.org/pipermail/openbsc/2017-September/011223.html )
- migration script/program that translates an OsmoNITB database to an OsmoHLR database.

#3 Updated by neels 10 months ago

  • Status changed from New to In Progress

#4 Updated by neels 10 months ago

on branch neels/subscr_vty, there is an enhancement+refactoring of the osmo-hlr db API to acommodate manipulating subscribers from the VTY (and CTRL), and extensive regression tests for the db API. There are initial implementations of VTY commands that still need VTY tests. Still pulling the commits apart into reviewable chunks and filling out the gaps. These patches should start hitting gerrit one of these days...

#5 Updated by neels 10 months ago

  • % Done changed from 0 to 50

#6 Updated by neels 9 months ago

  • % Done changed from 50 to 90

depends on osmo-python-tests https://gerrit.osmocom.org/4272 to add transcript based VTY testing,
and then the VTY commands are implemented in https://gerrit.osmocom.org/4273.
All db API changes have been merged, except for https://gerrit.osmocom.org/4230.

I will go on to change the basic enable-ps / disable-ps CTRL commands as described in
https://lists.osmocom.org/pipermail/openbsc/2017-September/011236.html
(not strictly part of this issue, but it matches the general flow before going back to the manual)

#7 Updated by neels 9 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

https://gerrit.osmocom.org/4273 has been merged.
The CTRL interface patch is still in review but looking good.
Resolving since CTRL is not actually related to adding subscribers.

#8 Updated by laforge 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)