Project

General

Profile

Bug #2559

ofono: EC20 shown no NetworkRegistration and MessageManage interfaces

Added by pespin 14 days ago. Updated 3 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
10/06/2017
Due date:
% Done:

0%

Spec Reference:

Description

I was trying to do some tests today with the Quectel EC20 in RnD setup:

# mdbus2 -s org.ofono /gobi_0 org.ofono.Modem.GetProperties
({'Online': <true>, 'Powered': <true>, 'Lockdown': <false>, 'Emergency': <false>, 'Manufacturer': <'Quectel'>, 'Model': <'EC20'>, 'Revision': <'EC20EQAR02A13E2G  1  [Jul  5 2017 10:49:17]'>, 'Serial': <'20120822'>, 'Interfaces': <['org.ofono.SimManager', 'org.ofono.LocationReporting', 'org.ofono.VoiceCallManager']>, 'Features': <['sim', 'gps']>, 'Type': <'hardware'>},)

However, even after Powered=true and Online=true, the org.ofono.NetworkRegistration and org.ofono.MessageManager interfaces don't show up:

root@osmo-gsm-tester-rnd:/opt/pespin/osmo-gsm-tester# mdbus2 -s org.ofono /gobi_0
[METHOD]   org.freedesktop.DBus.Introspectable.Introspect() -> (s:xml)
[METHOD]   org.ofono.Modem.GetProperties() -> (a{sv}:properties)
[METHOD]   org.ofono.Modem.SetProperty(s:property, v:value) -> ()
[SIGNAL]   org.ofono.Modem.PropertyChanged(s:name, v:value)
[METHOD]   org.ofono.VoiceCallManager.GetProperties() -> (a{sv}:properties)
[METHOD]   org.ofono.VoiceCallManager.Dial(s:number, s:hide_callerid) -> (o:path)
[METHOD]   org.ofono.VoiceCallManager.Transfer() -> ()
[METHOD]   org.ofono.VoiceCallManager.SwapCalls() -> ()
[METHOD]   org.ofono.VoiceCallManager.ReleaseAndAnswer() -> ()
[METHOD]   org.ofono.VoiceCallManager.ReleaseAndSwap() -> ()
[METHOD]   org.ofono.VoiceCallManager.HoldAndAnswer() -> ()
[METHOD]   org.ofono.VoiceCallManager.HangupAll() -> ()
[METHOD]   org.ofono.VoiceCallManager.PrivateChat(o:call) -> (ao:calls)
[METHOD]   org.ofono.VoiceCallManager.CreateMultiparty() -> (ao:calls)
[METHOD]   org.ofono.VoiceCallManager.HangupMultiparty() -> ()
[METHOD]   org.ofono.VoiceCallManager.SendTones(s:SendTones) -> ()
[METHOD]   org.ofono.VoiceCallManager.GetCalls() -> (a(oa{sv}):calls_with_properties)
[SIGNAL]   org.ofono.VoiceCallManager.Forwarded(s:type)
[SIGNAL]   org.ofono.VoiceCallManager.BarringActive(s:type)
[SIGNAL]   org.ofono.VoiceCallManager.PropertyChanged(s:name, v:value)
[SIGNAL]   org.ofono.VoiceCallManager.CallAdded(o:path, a{sv}:properties)
[SIGNAL]   org.ofono.VoiceCallManager.CallRemoved(o:path)
[METHOD]   org.ofono.LocationReporting.GetProperties() -> (a{sv}:properties)
[METHOD]   org.ofono.LocationReporting.Request() -> (h:fd)
[METHOD]   org.ofono.LocationReporting.Release() -> ()
[SIGNAL]   org.ofono.LocationReporting.PropertyChanged(s:name, v:value)
[METHOD]   org.ofono.SimManager.GetProperties() -> (a{sv}:properties)
[METHOD]   org.ofono.SimManager.SetProperty(s:property, v:value) -> ()
[METHOD]   org.ofono.SimManager.ChangePin(s:type, s:oldpin, s:newpin) -> ()
[METHOD]   org.ofono.SimManager.EnterPin(s:type, s:pin) -> ()
[METHOD]   org.ofono.SimManager.ResetPin(s:type, s:puk, s:newpin) -> ()
[METHOD]   org.ofono.SimManager.LockPin(s:type, s:pin) -> ()
[METHOD]   org.ofono.SimManager.UnlockPin(s:type, s:pin) -> ()
[METHOD]   org.ofono.SimManager.GetIcon(y:id) -> (ay:icon)
[SIGNAL]   org.ofono.SimManager.PropertyChanged(s:name, v:value)

As a result, osmo-gsm-tester fails with a timeout when using the EC20 because it expects and waits for those interfaces:

has_interface(org.ofono.NetworkRegistration, org.ofono.MessageManager) == False

History

#1 Updated by pespin 10 days ago

We cannot reproduce it at will. After restarting ofono (new version), we could power on and see all the interfaces correctly again.

#2 Updated by pespin 10 days ago

  • Status changed from New to Stalled

#3 Updated by pespin 3 days ago

  • Status changed from Stalled to Closed

Closing for now as we could not reproduce again.

Also available in: Atom PDF