Project

General

Profile

Bug #2912

osmo-bsc configuration in docker-playground has faulty encryption parameters

Added by dexter 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/07/2018
Due date:
% Done:

100%

Estimated time:
Spec Reference:

Description

For me all the tests that involve encryption and an assignment pass:

#BSC_Tests.TC_assignment_fr_a5_0 # Pass
#BSC_Tests.TC_assignment_fr_a5_1_codec_missing # Pass
#BSC_Tests.TC_assignment_fr_a5_1 # Pass
#BSC_Tests.TC_assignment_fr_a5_3 # Pass
#BSC_Tests.TC_assignment_fr_a5_4 # Pass

However, the osmo-bsc.cfg I can find in docker-playground (ttcn3-bsc-test) has only A5 0 activated. For the current test set we have it should be: encryption a5 0 1 3

History

#1 Updated by laforge 7 months ago

  • Assignee changed from laforge to dexter

feel free to push a related one-line fix to master.

#2 Updated by dexter 6 months ago

  • Status changed from New to Feedback
  • Assignee changed from dexter to laforge

Having problems to push. I guess my remote is wrong. Is this on gerrit? Do I have access rights?

#3 Updated by laforge 6 months ago

  • Assignee changed from laforge to dexter

It is at :docker-playground.git and your key has permissions. The permissions (and git push urls) are the same for all the non-gerrit repositories.

#4 Updated by dexter 6 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Since https://gerrit.osmocom.org/#/c/6544/ is now merged I have pushed the configuration change now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)