Project

General

Profile

Feature #2950

create OE-Package for osmo-sip-connector

Added by dexter about 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
-
Start date:
02/16/2018
Due date:
% Done:

100%

Resolution:

Description

It appears to be that osmo-sip-connector is not built as OE package, so it is not available for easy install on sysmoBTS or sysmoNITB. However, having osmo-sip-connector available on those platform would make sense.

Dependencies:
SOFIASIP, sofia-sip-ua-glib >= 1.12.0

History

#1 Updated by pespin about 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

Patch waiting for merge in https://gerrit.osmocom.org/#/c/6524.

Once it's merged, we need to merge in meta-sysmocom-bsp: branch pespin/osmo-sip-connector to 201705 to have it included in the feeds.

Once it's done and built, I'll assign to dexter for him to test it.

#2 Updated by pespin about 1 year ago

  • Assignee changed from pespin to dexter

Merged, and branches updated accordingly (rebased laforge/nightly on top of new 201705).

Packages should be built starting from tomorrow.

dexter you can try it out in your sysmobts (using either 201705-test or -nightly, both should have it), as you know better how to setup the SIP stuff.

BTW, I didn't upgrade yet OE recipes to use omo-mgw for MSC, because I'm waiting for the patches to use same mgw for bsc and MSC to land before doing the work. Which means that if you use nightly audio part will probably not work correctly out of the box (you'll need to stop osmo-bsc-mgcp and start a osmo-mgw manually).

#3 Updated by dexter 11 months ago

  • Priority changed from Normal to Low

The package basically has just has to be tried out and checked if it functions correctly. We decided to postpone this until this becomes relevant or when there is some spare-time.

#4 Updated by dexter 8 months ago

  • Status changed from Feedback to Stalled

#5 Updated by dexter 3 months ago

  • Status changed from Stalled to Resolved
  • % Done changed from 90 to 100

I have installed osmo-sip-connector on a sysmo-bts in order to see that the package installation works. Everything looks fine. I did not do a full test with a PBX setup etc, but I am confident that osmo-sip-connector will work fine on the sysmo-bts. I think we should close this now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)