Project

General

Profile

Bug #3115

libosmo-mgcp_client isn't able to properly encode SDP with multiple codec options

Added by laforge 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
libosmo-mgcp_client
Target version:
-
Start date:
03/26/2018
Due date:
% Done:

0%


Description

libosmo-mgcp_client doesn't seem capable of properly encoding SDP with multiple codec options

This is a problem, as both OsmoBSC as well as OsmoMSC need to be able to send the full list of available codecs to the MGW.


Related issues

Related to osmo-sip-connector - Bug #1683: osmo-sip-connector: Implement codec selectionNew2016-03-31

History

#1 Updated by laforge 7 months ago

  • Related to Bug #1683: osmo-sip-connector: Implement codec selection added

#2 Updated by laforge 4 months ago

  • Assignee changed from sysmocom to dexter

#3 Updated by dexter 4 months ago

  • Status changed from New to Feedback
  • Assignee changed from dexter to laforge

Probably I am overlooking/misunderstanding something here. Or this ticket is a duplicate of #3334. I am not sure.

From my understanding the client API has everything needed to negotiate multiple codec options. However, some parameters can not be altered, the sample rate (8000 in almost all cases) and the number of channels (always 1) can not be influenced. The ptime parameter (which is alsways 20 in our cases) can not be set individually for each codec. However I think it should, but SDP does not allow a per-codec ptime setting.

See: http://git.osmocom.org/osmo-mgw/tree/include/osmocom/mgcp_client/mgcp_client.h

In struct mgcp_msg

One findes two members:
enum mgcp_codecs codecs[MGCP_MAX_CODECS];
unsigned int codecs_len;

The member codecs can be populated with up to 10 codecs from enum mgcp_codecs. The payload types are automatically selected depending on IANA/3gpp recomendations. (If it is really necessary to map a codec to a different payload type one can do so by using the ptmap member.)

See also: https://osmocom.org/issues/3334

#4 Updated by laforge 4 months ago

  • Assignee changed from laforge to dexter

#5 Updated by laforge 4 months ago

If you think it is a duplicate and/or resolved, please resolve it. I just saw it,
and thought it relates to your current work and that's why I assigned it to you. There's no point in
assigning it back to me, so I have yet one more thing on my plate. Let's not play ticekt ping-pong. :/

#6 Updated by dexter 4 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)