Project

General

Profile

Bug #3290

osmo-pcu runtime errors due to clock drift in gprs_rlcmac_meas.cpp

Added by stsp over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/25/2018
Due date:
% Done:

0%

Spec Reference:

Description

The first jenkins verification run of https://gerrit.osmocom.org/#/c/osmo-pcu/+/9301/ failed because the substraction of two struct timevals lead to a negative number even though it should not:

(02:34:07 PM) stsp_: this failure in osmo-pcu jenkins looks like clock skew: +../../../src/gprs_rlcmac_meas.cpp:178:40: runtime error: left shift of negative value -999116
(02:34:20 PM) stsp_: also here: +../../../src/gprs_rlcmac_meas.cpp:134:42: runtime error: left shift of negative value -999039

Given the implicit assumption made in this code that time won't ever go backwards, it seems this code really wants to be using clock_gettime with CLOCK_MONOTONIC instead of gettimeofday().


Related issues

Is duplicate of OsmoPCU - Bug #3225: osmo-pcu: runtime error: left shift of negative value in gprs_rlcmac_rssiResolved05/02/2018

History

#1 Updated by pespin over 1 year ago

  • Is duplicate of Bug #3225: osmo-pcu: runtime error: left shift of negative value in gprs_rlcmac_rssi added

#2 Updated by stsp over 1 year ago

  • Status changed from New to Closed

Closing this issue since it is a duplicate of #3225.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)