Project

General

Profile

Bug #3456

pwsup_list in nanobts increasing size by extra 1 with every new test in a run

Added by pespin 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
08/08/2018
Due date:
% Done:

100%

Spec Reference:

Description

It was spotted today the nanobts powering on for 1 sec then powering off while running the osmo-gsm-teser-prod job. Also it was seen that both nanobts-1900 and nanobts-900 were on at the same time, which should not happen since we don't run tests in parallel yet.

Looking at debug logs while tests are run, it can be seen that first time nanobts.py is used everything's fine. Second time, pwsup_list is of size 2 (log "Powering cycling NanoBTS TRX" can be seen twice, as well as "Powering off NanoBTS TRX") while it should be of size 1 since we don't have any multitrx there. Third time, size=3, and so on. Then when the nanobts-900 tests are started later on, we can see in the pwsup_list that it still includes the old port1 (nanobts-1900) as well as one item for port2. Then during next tests, port2 is also duplicated.

As we see "Powering off NanoBTS TRX" being called, it looks improbable that somehow the list keeps its size from one test to the other one. So probably the issue is coming from a wrong value being calculated while filling the list in a loop in _configure(): for trx_i in range(self.num_trx()):

num_trx() is somehow returning increasing numbers? need to check by running several tests with nanobts together in RnD setup.

History

#2 Updated by pespin 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by pespin 4 months ago

  • Status changed from Feedback to Resolved

Merged and fixed, closing

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)