Project

General

Profile

Bug #3616

default (dynamic) ss7 config gets written to config file on write

Added by roh about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
10/02/2018
Due date:
% Done:

0%

Spec Reference:

Description

i verified this bug on osmo-msc nightly build today

to reproduce:
remove all occurences of cs7 from the config file.
restart osmo-msc
connect to vty
type 'write'
check config file.

it will contain at least this snippet in addition now:

cs7 instance 0
 point-code 0.23.1
 asp asp-clnt-OsmoMSC-A-Iu 2905 0 m3ua
  remote-ip 127.0.0.1
 as as-clnt-OsmoMSC-A-Iu m3ua
  asp asp-clnt-OsmoMSC-A-Iu
  routing-key 3 0.23.1
msc
 cs7-instance-a 0
 cs7-instance-iu 0

Associated revisions

Revision b59ebe9f (diff)
Added by Stefan Sperling almost 3 years ago

skip simple-client default as/asp when saving VTY config

When saving the current VTY config to a configuration file,
do not write out AS/ASP configuration items which are generated
as a fallback by osmo_sccp_simple_client_on_ss7_id().

Since the user did not explicitly configure these configuration
items they should not be saved to the user's configuration file.

Change-Id: Id8a3afc6dee29ae1ee9c862cbe404a61fe979dba
Related: OS#3616

History

#1 Updated by laforge about 3 years ago

  • Project changed from OsmoMSC to libosmo-sccp + libosmo-sigtran
  • Assignee set to stsp

this is most likely a libosmo-sigtran bug. The configuration should only write those parts which are explicitly configured, and not routes as/asp's which are dynamically created as automatism of the "simple client".

#2 Updated by stsp almost 3 years ago

Note that osmo-msc has to pass a default point code to the ss7 API (this is enforced by the API).

I suppose this means that this part will always have to be written out:

cs7 instance 0
 point-code 0.23.1

and thus also the following lines, because they reference this cs7 instance:

msc
 cs7-instance-a 0
 cs7-instance-iu 0

#3 Updated by stsp almost 3 years ago

  • Status changed from New to In Progress

#4 Updated by stsp almost 3 years ago

I have proposed a patch at https://gerrit.osmocom.org/#/c/libosmo-sccp/+/11509

This disables writing out default AS/ASP config items shown in the issue description.

#5 Updated by stsp almost 3 years ago

For consistency, I have checked the simple-server implementation for this problem as well.
It looks like dynamic AS/ASP created in server mode are already omitted from the configuration file when the config is written out.

Does anyone see anything else that needs to be done for this issue?

#6 Updated by stsp almost 3 years ago

  • Status changed from In Progress to Resolved

crickets

Sounds like nothing else seems to be needed. Closing this issue.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)