Project

General

Profile

Bug #3762

fix TC_mo_cc_bssmap_clear

Added by dexter 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/21/2019
Due date:
% Done:

100%

Resolution:

Description

The TTCN3 test TC_mo_cc_bssmap_clear is constantly not passing for a few days. Investigate whats wrong here.

History

#1 Updated by dexter 9 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

I think I found the cause for the problem. TC_lu_and_mt_sms_paging_and_nothing was using the same IMSI as TC_mo_cc_bssmap_clear. This leads to conflicts because the timed out paging from TC_lu_and_mt_sms_paging_and_nothing will start again and mess up TC_mo_cc_bssmap_clear. I have made sure that the two tests use individual IMSIs that do not repeat.

See also:
https://gerrit.osmocom.org/#/c/osmo-ttcn3-hacks/+/12681 MSC_Tests: individual IMSI for TC_lu_and_mt_sms_paging_and_nothing

#2 Updated by dexter 9 months ago

I am a bit confused now. Gerrit states that the patch above is merged. I can also confirm this locally with gitk. However, the tests still behave the old way. When I download the artifacts (archive.zip) from jenkins I can still see the old behavior (MSC_Tests.TC_lu_and_mt_sms_paging_and_nothing.pcap, ISMI=...43), while when I execute the test locally the behavior is as intended (MSC_Tests.TC_lu_and_mt_sms_paging_and_nothing_local.pcapng, IMSI=...1843)

I wonder if there are some problems with jenkins. Maybe it is not testing on the most recent state?

(see attached traces)

#3 Updated by dexter 9 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Now the test also passes on TC_mo_cc_bssmap_clear, so I believe that the change now has propagated to jenkins properly and we get the results as I expect. I think we can close this now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)