Project

General

Profile

Bug #3799

OsmoBSC send OML "Get Attributes" with wrong length value

Added by laforge 10 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
A-bis OML
Target version:
-
Start date:
02/12/2019
Due date:
% Done:

70%

Spec Reference:

Description

When sending the OML "GET ATTRIBUTES" message to the "Baseband Transceiver", OsmoBSC is sending a wrong "length" field of the OML message. See attached pcap file.

80 80 00 07 81 04 00 00 ff 1a 00 02 1c 41
         ^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
         |  10 bytes following   
         length octet stating len=7
20190212-oml-get_attr.pcap 20190212-oml-get_attr.pcap 123 Bytes laforge, 02/12/2019 06:32 PM

Related issues

Related to OsmoBSC - Bug #1614: better identification of BTS model / capabilities to BSCStalled02/23/2016

History

#1 Updated by laforge 10 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

will be working on a patch. The problem is that we have tons of old OsmoBSC versions around that do this wrong. This probably was wrong already in Change-Id I2b61131b9930afd03357c0b66947ee856d58cc46 merged in May 2017 - or possibly even longer than that...

#2 Updated by laforge 10 months ago

  • Related to Bug #1614: better identification of BTS model / capabilities to BSC added

#3 Updated by laforge 10 months ago

  • % Done changed from 10 to 70

A fix for OsmoBSC has been submitted as https://gerrit.osmocom.org/#/c/osmo-bsc/+/12890

A work-around for OsmoBTS has been submitted at https://gerrit.osmocom.org/#/c/osmo-bts/+/12891

#4 Updated by laforge 7 months ago

  • Status changed from In Progress to Resolved

both patches merged quite some time ago.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)