Project

General

Profile

Bug #3915

TC_lu_and_mt_call does not pass

Added by dexter 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/11/2019
Due date:
% Done:

0%

Resolution:

Description

The TTCN3 test TC_lu_and_mt_call does not pass for the last three consecutive test runs.

artifacts.tar.gz artifacts.tar.gz 5.98 MB dexter, 04/11/2019 08:37 AM

History

#1 Updated by dexter 8 months ago

I have done some investigation on this. The last three failures all have the following error in their logs.

04:38:56.752601 469 BSSMAP_Emulation.ttcn:412 Dynamic test case error: Data cannot be sent on port CLIENT to component 0 because there is no connection towards component 0.
04:38:56.752643 469 BSSMAP_Emulation.ttcn:412 setverdict(error): none -> error

I have tried to reproduce the problem locally but on my side the test is passing fine, even in Docker. Now I see that TC_lu_and_mt_call is passing in the last testrun on jenkins as well. The problem probably was temporary and is now gone. I will keep an eye on this. When the next few runs are ok we can close this.

#2 Updated by dexter 8 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)