Project

General

Profile

Bug #3941

investigate why TC_lu_and_mt_sms_paging_and_nothing suddelnly fails in ttcn3-msc-test-latest

Added by dexter about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/18/2019
Due date:
% Done:

100%

Resolution:

Description

In ttcn3-msc-test-latest TC_lu_and_mt_sms_paging_and_nothing now failes, but in ttcn3-msc-test it does pass. This meas that something in the testsuite has changed. We need to check why this effect occurs in order to make sure the problem is not related to some regression.

History

#1 Updated by dexter about 2 months ago

  • Status changed from New to In Progress

#2 Updated by dexter about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

I managed to pinpoint why the effect which is described above happens. With the recent changes in osmo-msc the behavior had been changed and due to the changed behavior the test expectation had to be changed. See the following to commits:

1623774b6860a51c43cb977261fe96dfac76a724
8256ed2aa93bc116b969426bc17165726460c20c

When checking out 628c005164ce3b6866a9afafdeca9b6bce5e199d, the problem vanishes.

I do not think that we have a problem here. The change was intentional.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)