Project

General

Profile

Bug #3960

fix TC_rsl_ms_pwr_ctrl and TC_si_sched_13_2bis_2ter_2quater

Added by dexter 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/26/2019
Due date:
% Done:

100%

Spec Reference:

Description

The tests fix TC_rsl_ms_pwr_ctrl and TC_si_sched_13_2bis_2ter_2quater fail since a delay after RSL initalization was introduced. Since the failure also appears with with latest, the problem must have been triggered by the change in the testsuite.

History

#1 Updated by dexter 6 months ago

  • Status changed from New to In Progress

I have analyzed the problem. For fix TC_rsl_ms_pwr_ctrl I can definitely say that the delay triggered the problem. However, I can see no direct connection between the delay and the testcase. The delay just causes to start the test later, but inside the test everything remained constant. Probably the delay before the test changed the conditions so that a race condition takes effect. I tried various things to relax the timing. I found out that it started working again when I wait for a short amount of time between the test loops.

A quick solution would be to remove the delay again. Its a module parameter anyway and the tests on real hardware can configure that accordingly.

#2 Updated by dexter 6 months ago

  • % Done changed from 0 to 40

The default settings remove the delay now:

https://gerrit.osmocom.org/#/c/osmo-ttcn3-hacks/+/13791 BTS_Tests: use 0.0 as default for mp_ipa_up_delay

#3 Updated by dexter 6 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

The patch is merged and the problem is gone now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)