Project

General

Profile

Bug #4260

regression: osmo-bsc cannot connect to osmo-stp after "ss7: Support multiple addresses in SCTP connections", when cs7 contains an 'asp' line

Added by neels 14 days ago. Updated 14 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/08/2019
Due date:
% Done:

100%

Spec Reference:

Description

In my test setup, without change of config, osmo-bsc suddenly does not connect to the STP anymore:

DLSS7 ERROR 0: asp-asp-clnt-msc-0: Unable to open stream client for ASP asp-clnt-msc-0 (osmo_ss7.c:1315)

and then obviously it keeps cycling through attempting to send a BSSMAP RESET to the MSC which never happens.

I've bisected this down to this commit being the causing change:

libosmo-sccp

commit 80b135581909fef595d48436ab04dbcb147e3895
Refs: [HEAD], [refs/bisect/bad], 1.1.0-15-g80b1355
Author:     Pau Espin Pedrol <pespin@sysmocom.de>
AuthorDate: Fri Oct 11 17:58:07 2019 +0200
Commit:     laforge <laforge@osmocom.org>
CommitDate: Tue Oct 22 19:38:53 2019 +0000

    ss7: Support multiple addresses in SCTP connections

My osmo-bsc.cfg, extract:

cs7 instance 0
 point-code 0.23.3
 asp asp-clnt-msc-0 2905 0 m3ua

After bisecting, I notice:
If I remove the line 'asp asp-clnt-msc-0 2905 0 m3ua', it works again.

How does this line manage to break connecting after this patch?
Can we make it so that it also still works even if such a line is in the config?


Related issues

Related to OsmoSTP - Bug #4247: XUA_ASP(asp-dyn-0){ASP_DOWN}: event ASPSM-ASP_UP not permitted in role ASPResolved11/06/2019

History

#1 Updated by fixeria 14 days ago

  • Related to Bug #4247: XUA_ASP(asp-dyn-0){ASP_DOWN}: event ASPSM-ASP_UP not permitted in role ASP added

#2 Updated by fixeria 14 days ago

I recently faced very similar problem. Can you attach the logs of OsmoSTP?

#3 Updated by pespin 14 days ago

Also a pcap file would be nice, as well as logs from BSC.

#4 Updated by pespin 14 days ago

Also please provide your full osmo-bsc.cfg as well as osmo-stp.cfg.

#5 Updated by pespin 14 days ago

Make sure you are using last libosmo-sccp master please, I think you are not using it (log line doesn't match current master). There's been some related fixes lately.

#6 Updated by pespin 14 days ago

  • Status changed from New to Feedback
  • Assignee changed from pespin to neels

#7 Updated by pespin 14 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)