Project

General

Profile

Bug #4738

compiling gr-osmosdr under ubuntu 20.04

Added by CSeguinot 26 days ago. Updated 26 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
08/31/2020
Due date:
% Done:

0%

Spec Reference:

Description

Hi

I've been able to use my rtl-sdr dongle by compiling gr-osmosdr (master branch) under Ubuntu 20.04/ GNURadio 3.8.2. However I uncountered a small issue that I report here.

Under Ubuntu 20.04 using command sudo apt install gnuradio install by default the latest version, 3.8.2 (as of september 2020). GNURadio libraries are installed under /usr/lib/x86_64-linux-gnu/.

Compiling gr-osmosdr, libgnuradio-osmosdr is installed in a different library under /usr/local/lib/x86_64-linux-gnu and is not found by GNURadio

In order to get a functional GNUradio, my workaround was to compile gr-osmosdr using cmake with a prefix:

cmake -DCMAKE_INSTALL_PREFIX=/usr ../

May be there is another solution?
This bug (is it really a bug?) is probably related to the way GNURAdio 3.8.2 is installed under Ubuntu 20.04.

Regards and many thanks to gr-osmosdr maintainers

History

#1 Updated by fixeria 26 days ago

Hey,

GNURadio libraries are installed under /usr/lib/x86_64-linux-gnu/
libgnuradio-osmosdr is installed in a different library under /usr/local/lib/x86_64-linux-gnu and is not found by GNURadio

yeah, it depends on your distribution in general. Debian and its deviations use '/usr/local', other distributions like Arch Linux use '/usr'. I am a bit surprised that on Ubuntu GNU Radio is installed under '/usr'. Such a mess...

cmake -DCMAKE_INSTALL_PREFIX=/usr ../
May be there is another solution?

What's wrong with this solution? You're explicitly specifying the prefix, looks ok to me.

This bug (is it really a bug?) is probably related to the way GNURAdio 3.8.2 is installed under Ubuntu 20.04.

It's better to ask the package maintainers why they decided to use '/usr' instead of '/usr/local'...

#2 Updated by fixeria 26 days ago

Debian and its deviations use '/usr/local', other distributions like Arch Linux use '/usr'.
It's better to ask the package maintainers why they decided to use '/usr' instead of '/usr/local'...

Ok, I seem to be wrong here. '/usr' is the default prefix for packages, '/usr/local' is for stuff compiled and installed manually.

#3 Updated by tnt 26 days ago

  • Status changed from New to Rejected

Not a bug, that's the intended and standard behavior.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)