Project

General

Profile

Bug #4901

New FSM error: transition to state DISABLED_NOTINSTALLED not permitted!

Added by fixeria 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
12/08/2020
Due date:
% Done:

100%

Spec Reference:

Description

I see this error message every time I restart osmo-bts-trx (in ttcn3-bts-test):

DNM ERROR nm_gprs_nsvc_fsm.c:306 NM_GPRS_NSVC_OP(nsvc1)[0x55ef21f6c170]{DISABLED_NOTINSTALLED}:
transition to state DISABLED_NOTINSTALLED not permitted!

I guess we can simply avoid DISABLED_NOTINSTALLED -> DISABLED_NOTINSTALLED state transition.


Related issues

Is duplicate of OsmoBSC - Bug #4831: nm_channel_fsm: bogus state transition message Resolved10/25/2020

Associated revisions

Revision 626b7a0b (diff)
Added by fixeria 10 months ago

NM FSMs: fix DISABLED_NOTINSTALLED -> DISABLED_NOTINSTALLED

This state transaction does not make sense, let's avoid it.

Change-Id: I24a78905bb684f8501dc5ade0605662ec283febc
Related: OS#4901

History

#1 Updated by fixeria 10 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 80

Should be fixed by:

https://gerrit.osmocom.org/c/osmo-bsc/+/21607 nm_gprs_nsvc_fsm: allow DISABLED_NOTINSTALLED -> DISABLED_NOTINSTALLED [NEW]

#2 Updated by pespin 10 months ago

  • Is duplicate of Bug #4831: nm_channel_fsm: bogus state transition message added

#3 Updated by pespin 10 months ago

  • Assignee changed from pespin to fixeria

My understanding is that fixeria is taking care of it. Please reassing back if you want me to take care of it. Same for #4831.

#4 Updated by pespin 10 months ago

  • Status changed from Feedback to Resolved

This specific one, general one for all FSMs being handled in #4901. Closing this one.

#5 Updated by fixeria 10 months ago

  • % Done changed from 80 to 100

Merged.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)