Gobi modems

To be used properly they require firmware loaded. Install gobi-loader and gobi-firmware packages from your distribution. If latter is missing than download firmware directly and place it into /lib/firmware/gobi using following links:

Also, make sure they are ignored by ModemManager - see Option Icon2 stick for details. Note that device id might change after firmware is loaded onto it.