Project

General

Profile

Bug #3197

dyn TS not configured properly during OML startup

Added by neels 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/23/2018
Due date:
% Done:

0%

Estimated time:
Spec Reference:

Description

I'm not sure if it's in osmo-bsc or osmo-bts yet.
During BTS startup, osmo-bsc tries to activate PDCH on TCH/F_TCH/H_PDCH dyn ts, which fails.
lchans seem stuck on dyn.pchan_is == NONE.
Though the BSC logs sending it, I can't see any OML Set Channel Attributes in the network trace.
BTS complains that "RSL rx DCHAN: mismatching chan_nr=0xc2", apparently because the channel is not initialized properly.


Related issues

Related to OsmoBSC - Bug #3205: dynamic timeslots initialized at the wrong timeResolved2018-04-23

History

#1 Updated by neels 4 months ago

the "Set Channel Attribute" messages are there, just because they are queued they don't appear close to the logging about it.
A bit further down it says:

1021    8.173752936    Apr 23, 2018 13:13:45.246200262 CEST    192.168.0.1    192.168.0.125            OML                        OML Radio Channel(00,00,03) Set Channel Attributes 

and
<0001> ../../../src/common/oml.c:905 Unknown/unhandled PCHAN type: 0 NONE

The Channel Activate requests are sent out on RSL even before the OML Set Channel Attributes are acked.

#2 Updated by neels 4 months ago

  • Related to Bug #3205: dynamic timeslots initialized at the wrong time added

#3 Updated by neels 4 months ago

  • Status changed from New to Rejected

gah, this was merely a missing line in my timeslot configuration.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)