Project

General

Profile

Bug #3310

Voice call always failed with Nokia 1600

Added by timojacobus 6 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
osmo-bts-trx
Target version:
-
Start date:
05/31/2018
Due date:
% Done:

100%

Spec Reference:

Description

Hi, I wasnt to report bug with our old Nokia 1600 mobile phones.

Problem: Incoming, outgoing call always failed if one of phones is Nokia 1600.

Detailed informations:
  • Calling from Nokia 1600 (extension 23855) to Google Nexus 5 (extension 23119)
  • Call fails after 30-45 seconds (seems like dropped by Nokia), Nokia without gsm signal.
  • PCAPs with RSL+OML and with gsmtap included
  • log files included
  • BTS+BSC configs included

We noticed that calls with Nokia will always fail after 30-45 seconds. Both outgoing and incoming calls. In RSL, there is CC Connect ACK, no CC Disconect or CC Release. When a call fails, then after some time the connection failure occurs.
At the beginning of call, voice is clear, about 10 seconds before drop is voice corrupted and then call fails.

Before call failed, there are many of entries of this type in log - "Received bad TCH frame ending at fn=619067 for TCH/F". We tried also same RX gain/TX atten. modifications, also MS power settings, but with no effect.

With another different phones, calls work perfectly, so we suspecting the undefined behaviour of Nokia 1600 (https://www.gsmarena.com/nokia_1600-1188.php)

Tests:
1. call accepted, call failed
2. call accepted, call failed (longer pcap with connection failure)
3. only alerting, call failed

HW:
Ettus B200 with external clock
Nokia 1600 (tried several phones same type)
LG Nexus 5

SW:
UHD_003.009.006-0-g122d5f8e
gnuradio 3.7.11

libosmocore 0.9.6
libosmo-abis 0.3.3
libosmo-netif 0.0.7
osmo-trx 0.1.9
osmo-bts 0.5.0
OpenBSC version 0.15.0.788-271ce

Also tried with latest versions, but with same results
UHD_3.12.0.git-159-g9cf1a8e9
gnuradio 3.7.12

libosmocore 0.11.0
libosmo-abis 0.5.0
libosmo-netif 0.2.0
osmo-trx 0.4.0
osmo-bts 0.8.0
OpenBSC version 1.1.0
log_1.txt log_1.txt 2.82 MB timojacobus, 05/31/2018 12:52 PM
log_2.txt log_2.txt 2.75 MB timojacobus, 05/31/2018 12:52 PM
log_3.txt log_3.txt 2.4 MB timojacobus, 05/31/2018 12:52 PM
pcap_1_clean.pcapng pcap_1_clean.pcapng 214 KB timojacobus, 05/31/2018 12:52 PM
pcap_2_clean.pcapng pcap_2_clean.pcapng 143 KB timojacobus, 05/31/2018 12:52 PM
pcap_3_clean.pcapng pcap_3_clean.pcapng 132 KB timojacobus, 05/31/2018 12:52 PM
osmo-bts.cfg osmo-bts.cfg 1.27 KB timojacobus, 05/31/2018 12:52 PM
openbsc.cfg openbsc.cfg 1.6 KB timojacobus, 05/31/2018 12:52 PM
bsc.hlr bsc.hlr 27 KB timojacobus, 05/31/2018 12:52 PM
osmo-trx.cfg osmo-trx.cfg 357 Bytes timojacobus, 07/11/2018 08:34 AM

History

#1 Updated by laforge 5 months ago

  • Assignee set to roh
  • Priority changed from Normal to Low
  • % Done changed from 0 to 10

I ordered a Nokia 1600. roh, please try to reproduce the problem with the phone, once it arrives.

#2 Updated by roh 5 months ago

hi. i got the nokia1600 laforge ordered, but sadly the phone reports 'ungueltige sim' -> 'sim invalid' which means it is likely simlocked, contrary to the labeling 'ohne simlock' on the package.
seems we need to either get another phone or unlock this one first.

timojacobus: can you please add your osmo-trx-uhd.cfg as well?
also it would be interesting to know which builds you use for testing. i am using the debian9 feed 'latest'

#3 Updated by roh 5 months ago

timojacobus: another question would be what kind of clock-source do you use for the usrp? some gps-disciplined oscillator?

kind regards

#4 Updated by laforge 5 months ago

On Thu, Jun 28, 2018 at 07:11:07PM +0000, roh [REDMINE] wrote:

hi. i got the nokia1600 laforge ordered, but sadly the phone reports 'ungueltige sim' -> 'sim invalid' which means it is likely simlocked, contrary to the labeling 'ohne simlock' on the package.

I've notified the seller about this. Would be interesting to try with some cards
that have 26201 / 26202 / 26207 as operator code.

#5 Updated by roh 5 months ago

i have tried some old tchibo sim of mine, which i think uses the o2
network and it asked me for a pin i cannot remember anymore instead of
the error message.

#6 Updated by timojacobus 4 months ago

roh wrote:

timojacobus: another question would be what kind of clock-source do you use for the usrp? some gps-disciplined oscillator?

kind regards

Hi, I added osmo-trx.cfg file (from latest configuration). Clock source in not original Ettus TCXO module, but custom precise oscillator.

#7 Updated by roh about 2 months ago

  • Status changed from New to In Progress

i just tried it in a 'old nitb & old sysmobts' setup and it worked for me (voice call, no issues)

will test with osmo-trx at the next opportunity

#8 Updated by roh about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100

i have just tested the nokia1600 in a voice call to a samsung s4mini on a cell running on a usrp b200 using the nightly builds of our debian9 feed. (split-nitb)

there is voice in both directions and the call is stable. codec is FR.

clock is from a E4406A.

@timojacobus: sure your clock is proper? (correct slope/levels etc?)

sorry - i could not reproduce this problem.

osmo-trx-uhd.cfg:

log stderr
 logging filter all 1
 logging color 1
 logging print category 1
 logging timestamp 1
 logging print file basename
 logging level all info
!
line vty
 no login
!
trx
 bind-ip 127.0.0.1
 remote-ip 127.0.0.1
 base-port 5700
 egprs disable
 tx-sps 4
 rx-sps 4
 clock-ref external
 rt-prio 18
 chan 0

osmo-bts.cfg

log stderr
  logging color 1
  logging timestamp 0
  logging level rsl notice
  logging level oml notice
  logging level rll notice
  logging level rr notice
  logging level meas error
  logging level pag error
  logging level l1c error
  logging level l1p error
  logging level dsp error
  logging level abis error
!
line vty
 no login
!
phy 0
 instance 0
  osmotrx rx-gain 1
  osmotrx tx-attenuation 1
 osmotrx ip local 127.0.0.1
 osmotrx ip remote 127.0.0.1
bts 0
 band 1800
 ipa unit-id 1801 0
 oml remote-ip 127.0.0.1
 gsmtap-sapi ccch
 gsmtap-sapi pdtch
 trx 0
  phy 0 instance 0

osmo-bsc.cfg

log stderr
  logging filter all 1
  logging color 0
  logging print category 0
  logging timestamp 0
  logging print file 1
  logging level all everything
  logging level rll notice
  logging level mm notice
  logging level rr notice
  logging level rsl notice
  logging level nm info
  logging level pag notice
  logging level meas notice
  logging level msc notice
  logging level ho notice
  logging level hodec notice
  logging level ref notice
  logging level nat notice
  logging level ctrl notice
  logging level filter debug
  logging level pcu debug
  logging level lcls notice
  logging level lglobal notice
  logging level llapd notice
  logging level linp notice
  logging level lmux notice
  logging level lmi notice
  logging level lmib notice
  logging level lsms notice
  logging level lctrl notice
  logging level lgtp notice
  logging level lstats notice
  logging level lgsup notice
  logging level loap notice
  logging level lss7 notice
  logging level lsccp notice
  logging level lsua notice
  logging level lm3ua notice
  logging level lmgcp notice
  logging level ljibuf notice
!
stats interval 5
!
line vty
 no login
!
e1_input
 e1_line 0 driver ipa
network
 network country code 901
 mobile network code 70
 encryption a5 0
 neci 1
 paging any use tch 0
 handover 0
 handover algorithm 1
 handover1 window rxlev averaging 10
 handover1 window rxqual averaging 1
 handover1 window rxlev neighbor averaging 10
 handover1 power budget interval 6
 handover1 power budget hysteresis 3
 handover1 maximum distance 9999
 dyn_ts_allow_tch_f 0
 periodic location update 30
 bts 0
  type sysmobts
  band DCS1800
  cell_identity 0
  location_area_code 1
  base_station_id_code 63
  ms max power 15
  cell reselection hysteresis 4
  rxlev access min 0
  radio-link-timeout 32
  channel allocator ascending
  rach tx integer 9
  rach max transmission 7
  channel-descrption attach 1
  channel-descrption bs-pa-mfrms 5
  channel-descrption bs-ag-blks-res 1
  early-classmark-sending forbidden
  ip.access unit_id 1801 0
  oml ip.access stream_id 255 line 0
  neighbor-list mode manual-si5
  neighbor-list add arfcn 100
  neighbor-list add arfcn 200
  si5 neighbor-list add arfcn 10
  si5 neighbor-list add arfcn 20
  codec-support fr
  gprs mode none
  no force-combined-si
  trx 0
   rf_locked 0
   arfcn 871
   nominal power 23
   max_power_red 10
   rsl e1 tei 0
   timeslot 0
    phys_chan_config CCCH+SDCCH4
    hopping enabled 0
   timeslot 1
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 2
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 3
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 4
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 5
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 6
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 7
    phys_chan_config TCH/F
    hopping enabled 0
msc 0
 no bsc-welcome-text
 no bsc-msc-lost-text
 no bsc-grace-text
 codec-list fr1
 type normal
 allow-emergency allow
 amr-config 12_2k forbidden
 amr-config 10_2k forbidden
 amr-config 7_95k forbidden
 amr-config 7_40k forbidden
 amr-config 6_70k forbidden
 amr-config 5_90k allowed
 amr-config 5_15k forbidden
 amr-config 4_75k forbidden
 mgw remote-ip 127.0.0.1
 mgw remote-port 2427
 mgw local-port 2727
 mgw endpoint-range 1 31
bsc
 mid-call-timeout 0
 no missing-msc-text

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)