Project

General

Profile

Bug #4183

osmo-gsm-manuals failures on OBS for quite some time

Added by laforge 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
08/30/2019
Due date:
% Done:

100%

Spec Reference:

Description

Visit https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/osmo-gsm-manuals/Debian_Unstable/x86_64

Package network:osmocom:nightly/osmo-gsm-manuals failed to build in Debian_Unstable/x86_64

Check out the package for editing:
osc checkout network:osmocom:nightly osmo-gsm-manuals

Last lines of build log:

[  564s] asciidoc: test-usermanual.adoc: line 28: reading:
/usr/src/packages/BUILD/common/chapters/gfdl.adoc
[  564s] asciidoc: include: /usr/src/packages/BUILD/common/chapters/smpp.adoc
[  565s] asciidoc: test-usermanual.adoc: line 29: reading:
/usr/src/packages/BUILD/common/chapters/smpp.adoc
[  565s] asciidoc: include: /usr/src/packages/BUILD/common/chapters/sigtran.adoc
[  565s] asciidoc: test-usermanual.adoc: line 30: reading:
/usr/src/packages/BUILD/common/chapters/sigtran.adoc
[  565s] asciidoc: include: /usr/src/packages/BUILD/common/chapters/mncc.adoc
[  565s] asciidoc: test-usermanual.adoc: line 31: reading:
/usr/src/packages/BUILD/common/chapters/mncc.adoc
[  565s] asciidoc: include: /usr/src/packages/BUILD/common/chapters/abis.adoc
[  565s] asciidoc: test-usermanual.adoc: line 32: reading:
/usr/src/packages/BUILD/common/chapters/abis.adoc
[  565s]
[  565s] make[3]: *** [../build/Makefile.asciidoc.inc:69: test-usermanual.pdf] Error 1
[  565s] make[3]: Leaving directory '/usr/src/packages/BUILD/tests'
[  565s] make[2]: *** [Makefile:438: all-recursive] Error 1
[  565s] make[2]: Leaving directory '/usr/src/packages/BUILD'
[  565s] make[1]: *** [Makefile:362: all] Error 2
[  565s] make[1]: Leaving directory '/usr/src/packages/BUILD'
[  565s] dh_auto_build: make -j1 returned exit code 2
[  565s] make: *** [debian/rules:5: binary] Error 255
[  565s] dpkg-buildpackage: error: fakeroot debian/rules binary subprocess returned exit status 2
[  565s]
[  565s] lamb59 failed "build osmo-gsm-manuals-dev_0.2.0.dsc" at Fri Aug 30 02:37:43 UTC 2019.
[  565s]
[  565s] ### VM INTERACTION START ###
[  568s] [  543.931958] sysrq: SysRq : Power Off
[  568s] [  543.947767] reboot: Power down
[  568s] ### VM INTERACTION END ###
[  568s]
[  568s] lamb59 failed "build osmo-gsm-manuals-dev_0.2.0.dsc" at Fri Aug 30 02:37:47 UTC 2019.
[  568s]

History

#1 Updated by osmith 3 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#2 Updated by osmith 3 months ago

Further above in the log:

[  564s] asciidoc: ERROR: mgcp_extension_osmux.adoc: line 2: glossary section cannot contain sub-sections

So it seems that newer asciidoc versions throw an error if we begin sub-sections (=== headlines) after starting the glossary with "[glossary]". I'm preparing a patch, that makes sure, that glossary.adoc is included as last file when building the test manual (which includes all common chapters).

#3 Updated by osmith 3 months ago

  • % Done changed from 0 to 90

#4 Updated by osmith 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

It is building again.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)